portage.package.ebuild._config.UseManager module

class portage.package.ebuild._config.UseManager.UseManager(repositories, profiles, abs_user_config, is_stable, user_config=True)

Bases: object

_isStable(pkg)
_parse_file_to_dict(file_name, juststrings=False, recursive=True, eapi_filter=None, user_config=False, eapi=None, eapi_default='0', allow_repo=False, allow_build_id=False)
Parameters
  • file_name (str) – input file name

  • juststrings (bool) – store dict values as space-delimited strings instead of tuples

  • recursive (bool) – triggers recursion if the input file is a directory

  • eapi_filter (callable) – a function that accepts a single eapi argument, and returns true if the current file type is supported by the given EAPI

  • user_config (bool) – current file is part of the local configuration (not repository content)

  • eapi (str) – the EAPI of the current profile node, which allows a call to read_corresponding_eapi_file to be skipped

  • eapi_default (str) – the default EAPI which applies if the current profile node does not define a local EAPI

  • allow_build_id (bool) – allow atoms to specify a particular build-id

Return type

tuple

Returns

collection of USE flags

_parse_file_to_tuple(file_name, recursive=True, eapi_filter=None, eapi=None, eapi_default='0')
Parameters
  • file_name (str) – input file name

  • recursive (bool) – triggers recursion if the input file is a directory

  • eapi_filter (callable) – a function that accepts a single eapi argument, and returns true if the current file type is supported by the given EAPI

  • eapi (str) – the EAPI of the current profile node, which allows a call to read_corresponding_eapi_file to be skipped

  • eapi_default (str) – the default EAPI which applies if the current profile node does not define a local EAPI

Return type

tuple

Returns

collection of USE flags

_parse_profile_files_to_tuple_of_dicts(file_name, locations, juststrings=False, eapi_filter=None)
_parse_profile_files_to_tuple_of_tuples(file_name, locations, eapi_filter=None)
_parse_repository_files_to_dict_of_dicts(file_name, repositories, eapi_filter=None)
_parse_repository_files_to_dict_of_tuples(file_name, repositories, eapi_filter=None)
_parse_user_files_to_extatomdict(file_name, location, user_config)
extract_global_USE_changes(old='')
getPUSE(pkg)
getUseForce(pkg=None, stable=None)
getUseMask(pkg=None, stable=None)