portage.package.ebuild._config.MaskManager module

class portage.package.ebuild._config.MaskManager.MaskManager(repositories, profiles, abs_user_config, user_config=True, strict_umatched_removal=False)

Bases: object

_getMaskAtom(cpv, slot, repo, unmask_atoms=None)

Take a package and return a matching package.mask atom, or None if no such atom exists or it has been cancelled by package.unmask.

Parameters
  • cpv (String) – The package name

  • slot (String) – The package’s slot

  • repo (String) – The package’s repository [optional]

  • unmask_atoms (list) – if desired pass in self._punmaskdict.get(cp)

Return type

String

Returns

A matching atom string or None if one is not found.

getMaskAtom(cpv, slot, repo)

Take a package and return a matching package.mask atom, or None if no such atom exists or it has been cancelled by package.unmask.

Parameters
  • cpv (String) – The package name

  • slot (String) – The package’s slot

  • repo (String) – The package’s repository [optional]

Return type

String

Returns

A matching atom string or None if one is not found.

getRawMaskAtom(cpv, slot, repo)

Take a package and return a matching package.mask atom, or None if no such atom exists. It HAS NOT! been cancelled by any package.unmask.

Parameters
  • cpv (String) – The package name

  • slot (String) – The package’s slot

  • repo (String) – The package’s repository [optional]

Return type

String

Returns

A matching atom string or None if one is not found.