portage.package.ebuild._ipc.QueryCommand module

class portage.package.ebuild._ipc.QueryCommand.QueryCommand(settings, phase)

Bases: portage.package.ebuild._ipc.IpcCommand.IpcCommand

_db = None
_elog(elog_funcname, lines)

This returns a string, to be returned via ipc and displayed at the appropriate place in the build output. We wouldn’t want to open the log here since it is already opened by AbstractEbuildProcess and we don’t want to corrupt it, especially if it is being written with compression.

classmethod get_db()
phase
settings